p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости cups

За последние 30 дней в cups опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 14

  1. CVE-2023-32324

    Высокий · CVSS 7.5EPSS 1,46%Есть исправление

    OpenPrinting CUPS vulnerable to heap buffer overflow

    OpenPrinting CUPS is an open source printing system. In versions 2.4.2 and prior, a heap buffer overflow vulnerability would allow a remote attacker to launch a denial of service (DoS) attack. A buffer overflow vulnerability in the function `format_log_line` could allow remote attackers to cause a DoS on the affected system. Exploitation of the vulnerability can be triggered when the configuration file `cupsd.conf` sets the value of `loglevel `to `DEBUG`. No known patches or workarounds exist at time of publication.

    • Обновитесь до 2.2.7-1ubuntu2.10
  2. CVE-2022-26691

    Средний · CVSS 6.7EPSS 0,6%Есть исправление

    CVE-2022-26691

    A logic issue was addressed with improved state management. This issue is fixed in Security Update 2022-003 Catalina, macOS Monterey 12.3, macOS Big Sur 11.6.5. An application may be able to gain elevated privileges.

    • Обновитесь до 2.2.7-1ubuntu2.9
  3. CVE-2020-10001

    Средний · CVSS 5.5EPSS 1,04%Есть исправление

    CVE-2020-10001

    An input validation issue was addressed with improved memory handling. This issue is fixed in macOS Big Sur 11.1, Security Update 2020-001 Catalina, Security Update 2020-007 Mojave. A malicious application may be able to read restricted memory.

    • Обновитесь до 2.2.7-1ubuntu2.9
    Опубликовано Обновлено
  4. CVE-2019-8842

    Низкий · CVSS 3.3EPSS 2,03%Есть исправление

    CVE-2019-8842

    A buffer overflow was addressed with improved bounds checking. This issue is fixed in macOS Catalina 10.15.2, Security Update 2019-002 Mojave, and Security Update 2019-007 High Sierra. In certain configurations, a remote attacker may be able to submit arbitrary print jobs.

    • Обновитесь до 2.2.7-1ubuntu2.9
    Опубликовано Обновлено
  5. CVE-2019-8696

    Высокий · CVSS 8.8EPSS 2,18%Есть исправление

    CVE-2019-8696

    A buffer overflow issue was addressed with improved memory handling. This issue is fixed in macOS Mojave 10.14.6, Security Update 2019-004 High Sierra, Security Update 2019-004 Sierra. An attacker in a privileged network position may be able to execute arbitrary code.

    • Обновитесь до 2.2.7-1ubuntu2.7
    Опубликовано Обновлено
  6. CVE-2019-8675

    Высокий · CVSS 8.8EPSS 2,12%Есть исправление

    CVE-2019-8675

    A buffer overflow issue was addressed with improved memory handling. This issue is fixed in macOS Mojave 10.14.6, Security Update 2019-004 High Sierra, Security Update 2019-004 Sierra. An attacker in a privileged network position may be able to execute arbitrary code.

    • Обновитесь до 2.2.7-1ubuntu2.7
    Опубликовано Обновлено
  7. CVE-2020-3898

    Высокий · CVSS 7.8EPSS 0,39%Есть исправление

    CVE-2020-3898

    A memory corruption issue was addressed with improved validation. This issue is fixed in macOS Catalina 10.15.4. An application may be able to gain elevated privileges.

    • Обновитесь до 2.2.7-1ubuntu2.8
    Опубликовано Обновлено
  8. CVE-2019-2228

    Средний · CVSS 5.5EPSS 0,2%Есть исправление

    CVE-2019-2228

    In array_find of array.c, there is a possible out-of-bounds read due to an incorrect bounds check. This could lead to local information disclosure in the printer spooler with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android-8.0 Android-8.1 Android-9 Android-10Android ID: A-111210196

    • Обновитесь до 2.2.7-1ubuntu2.8
    Опубликовано Обновлено
  9. CVE-2019-2180

    Средний · CVSS 5.5EPSS 0,18%Есть исправление

    CVE-2019-2180

    In ippSetValueTag of ipp.c in Android 8.0, 8.1 and 9, there is a possible out of bounds read due to improper input validation. This could lead to local information disclosure from the printer service with no additional execution privileges needed. User interaction is not needed for exploitation.

    • Обновитесь до 2.2.7-1ubuntu2.7
    Опубликовано Обновлено
  10. CVE-2018-4300

    Средний · CVSS 5.9EPSS 1,84%Есть исправление

    CVE-2018-4300

    The session cookie generated by the CUPS web interface was easy to guess on Linux, allowing unauthorized scripted access to the web interface when the web interface is enabled. This issue affected versions prior to v2.2.10.

    • Обновитесь до 2.2.7-1ubuntu2.2
    Опубликовано Обновлено
  11. CVE-2018-4181

    Средний · CVSS 5.5EPSS 0,45%Есть исправление

    CVE-2018-4181

    In macOS High Sierra before 10.13.5, an issue existed in CUPS. This issue was addressed with improved access restrictions.

    • Обновитесь до 2.2.7-1ubuntu2.1
    Опубликовано Обновлено
  12. CVE-2018-4180

    Высокий · CVSS 7.8EPSS 0,45%Есть исправление

    CVE-2018-4180

    In macOS High Sierra before 10.13.5, an issue existed in CUPS. This issue was addressed with improved access restrictions.

    • Обновитесь до 2.2.7-1ubuntu2.1
    Опубликовано Обновлено
  13. CVE-2018-4700

    Без оценкиЕсть исправление

    UBUNTU-CVE-2018-4700

    Rejected reason: DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: CVE-2018-4300. Reason: This candidate is a duplicate of CVE-2018-4300. Notes: All CVE users should reference CVE-2018-4300 instead of this candidate. All references and descriptions in this candidate have been removed to prevent accidental usage

    • Обновитесь до 2.2.7-1ubuntu2.2
    Опубликовано Обновлено
  14. CVE-2018-6553

    Высокий · CVSS 8.8EPSS 0,39%Есть исправление

    AppArmor cupsd Sandbox Bypass Due to Use of Hard Links

    The CUPS AppArmor profile incorrectly confined the dnssd backend due to use of hard links. A local attacker could possibly use this issue to escape confinement. This flaw affects versions prior to 2.2.7-1ubuntu2.1 in Ubuntu 18.04 LTS, prior to 2.2.4-7ubuntu3.1 in Ubuntu 17.10, prior to 2.1.3-4ubuntu0.5 in Ubuntu 16.04 LTS, and prior to 1.7.2-0ubuntu1.10 in Ubuntu 14.04 LTS.

    • Обновитесь до 2.2.7-1ubuntu2.1
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →