p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости cups

За последние 30 дней в cups опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 11

  1. CVE-2024-47175

    Высокий · CVSS 8.6EPSS 63,61%Публичный эксплойтЕсть исправление

    libppd's ppdCreatePPDFromIPP2 function does not sanitize IPP attributes when creating the PPD buffer

    CUPS is a standards-based, open-source printing system, and `libppd` can be used for legacy PPD file support. The `libppd` function `ppdCreatePPDFromIPP2` does not sanitize IPP attributes when creating the PPD buffer. When used in combination with other functions such as `cfGetPrinterAttributes5`, can result in user controlled input and ultimately code execution via Foomatic. This vulnerability can be part of an exploit chain leading to remote code execution (RCE), as described in CVE-2024-47176.

    • Обновитесь до 2.3.1-9ubuntu1.9
    Опубликовано Обновлено
  2. USN-6844-2

    Без оценкиЕсть исправление

    cups regression

    USN-6844-1 fixed vulnerabilities in the CUPS package. The update lead to the discovery of a regression in CUPS with regards to how the cupsd daemon handles Listen configuration directive. This update fixes the problem. We apologize for the inconvenience. Original advisory details: Rory McNamara discovered that when starting the cupsd server with a Listen configuration item, the cupsd process fails to validate if bind call passed. An attacker could possibly trick cupsd to perform an arbitrary chmod of the provided argument, providing world-writable access to the target.

    • Обновитесь до 2.3.1-9ubuntu1.8
  3. CVE-2024-35235

    Средний · CVSS 4.4EPSS 2,42%Есть исправление

    Cupsd Listen arbitrary chmod 0140777

    OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. In versions 2.4.8 and earlier, when starting the cupsd server with a Listen configuration item pointing to a symbolic link, the cupsd process can be caused to perform an arbitrary chmod of the provided argument, providing world-writable access to the target. Given that cupsd is often running as root, this can result in the change of permission of any user or system files to be world writable. Given the aforementioned Ubuntu AppArmor context, on such systems this vulnerability is limited to those files modifiable by the cupsd process. In that s

    • Обновитесь до 2.3.1-9ubuntu1.7
    Опубликовано Обновлено
  4. CVE-2023-4504

    Высокий · CVSS 7EPSS 0,64%Есть исправление

    OpenPrinting CUPS/libppd Postscript Parsing Heap Overflow

    Due to failure in validating the length provided by an attacker-crafted PPD PostScript document, CUPS and libppd are susceptible to a heap-based buffer overflow and possibly code execution. This issue has been fixed in CUPS version 2.4.7, released in September of 2023.

    • Обновитесь до 2.3.1-9ubuntu1.6
    Опубликовано Обновлено
  5. CVE-2023-32360

    Средний · CVSS 5.5EPSS 0,33%Есть исправление

    CVE-2023-32360

    An authentication issue was addressed with improved state management. This issue is fixed in macOS Big Sur 11.7.7, macOS Monterey 12.6.6, macOS Ventura 13.4. An unauthenticated user may be able to access recently printed documents.

    • Обновитесь до 2.3.1-9ubuntu1.5
    Опубликовано Обновлено
  6. CVE-2023-34241

    Средний · CVSS 5.3EPSS 1,38%Есть исправление

    CUPS vulnerable to use-after-free in cupsdAcceptClient()

    OpenPrinting CUPS is a standards-based, open source printing system for Linux and other Unix-like operating systems. Starting in version 2.0.0 and prior to version 2.4.6, CUPS logs data of free memory to the logging service AFTER the connection has been closed, when it should have logged the data right before. This is a use-after-free bug that impacts the entire cupsd process. The exact cause of this issue is the function `httpClose(con->http)` being called in `scheduler/client.c`. The problem is that httpClose always, provided its argument is not null, frees the pointer at the end of the call, only for cupsdLogClient to pass the pointer to

    • Обновитесь до 2.3.1-9ubuntu1.4
    Опубликовано Обновлено
  7. CVE-2023-32324

    Высокий · CVSS 7.5EPSS 1,46%Есть исправление

    OpenPrinting CUPS vulnerable to heap buffer overflow

    OpenPrinting CUPS is an open source printing system. In versions 2.4.2 and prior, a heap buffer overflow vulnerability would allow a remote attacker to launch a denial of service (DoS) attack. A buffer overflow vulnerability in the function `format_log_line` could allow remote attackers to cause a DoS on the affected system. Exploitation of the vulnerability can be triggered when the configuration file `cupsd.conf` sets the value of `loglevel `to `DEBUG`. No known patches or workarounds exist at time of publication.

    • Обновитесь до 2.3.1-9ubuntu1.3
  8. CVE-2022-26691

    Средний · CVSS 6.7EPSS 0,6%Есть исправление

    CVE-2022-26691

    A logic issue was addressed with improved state management. This issue is fixed in Security Update 2022-003 Catalina, macOS Monterey 12.3, macOS Big Sur 11.6.5. An application may be able to gain elevated privileges.

    • Обновитесь до 2.3.1-9ubuntu1.2
  9. CVE-2020-10001

    Средний · CVSS 5.5EPSS 1,04%Есть исправление

    CVE-2020-10001

    An input validation issue was addressed with improved memory handling. This issue is fixed in macOS Big Sur 11.1, Security Update 2020-001 Catalina, Security Update 2020-007 Mojave. A malicious application may be able to read restricted memory.

    • Обновитесь до 2.3.1-9ubuntu1.2
    Опубликовано Обновлено
  10. CVE-2019-8842

    Низкий · CVSS 3.3EPSS 2,03%Есть исправление

    CVE-2019-8842

    A buffer overflow was addressed with improved bounds checking. This issue is fixed in macOS Catalina 10.15.2, Security Update 2019-002 Mojave, and Security Update 2019-007 High Sierra. In certain configurations, a remote attacker may be able to submit arbitrary print jobs.

    • Обновитесь до 2.3.1-9ubuntu1.2
    Опубликовано Обновлено
  11. CVE-2020-3898

    Высокий · CVSS 7.8EPSS 0,39%Есть исправление

    CVE-2020-3898

    A memory corruption issue was addressed with improved validation. This issue is fixed in macOS Catalina 10.15.4. An application may be able to gain elevated privileges.

    • Обновитесь до 2.3.1-9ubuntu1.1
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →